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CIS 119 – Project Management


Getting Started with Turbo/GigaProject

To start the program , use the “Start” menu to find the application as shown in figure T.T.1 . 

[image: image1.png]Accessories »
Startup 3
Internet Explorer

Outlook Express

Active Worlds
T Pegasus Mal for Win32
Wiz
Ws_FTP
il Real
& Adobe

Adobe Acrobat 4.0
st

ODBC

Diploma

IT Todsy Instructor D
TurboProject Professionsl
Course Test Manager

GigsProject v4.5 Readime
ETS NEXT Demanstration |

Photoworks Plus v2.41 >
Yahoo! Messenger >
Micrasoft Project l
Mirasoft Offce Tools > o]

|

Windaws Update
Winzip

Yahao! Messenger

New Office Document

Open Offics Document

Netscape SmartUpdiate

Micrasoft Access
Documents Micrasalt Excel
Micrasoft FrontPage
Microsoft Outiook L
Micrasaft PowerPeint
Micrasoft Word
Audioglary

Supervaice
SETIGhome

Netscape Communicator
QuickTime

McAfes.com Agent

Sattings

searth
Help

Run,

Shut Down.

YOG BD szum

=
271





Figure T.T.1

When the program loads you will see the “Welcome” dialog box. Along with other option the “Welcome” dialog box will provide you with a means of starting the software in the 3 most common ways: “Work on Last Project”, “Work on Existing Project” and “Create a New Project”. The Welcome dialog box is shown in figure T.T.2.
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Figure T.T.2

Select the “Create a New Project” option. Turbo/GigaProject will open in one of the standard views (If it opens in anything but the Network View we will be changing it shortly). In the middle of the screen the “Project Information” dialog box is displayed (see figure T.T.3). Give the Project a short name and a description. For now we will not change anything else we will see how to change those later.
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Figure T.T.3

On the left side of the program there will be a “Views” menu. Select the view that says “Network” . The Network view is the starting point for the creation of a new project plan. Figure TT.4 shows the left side of the Network view.

[image: image4.png][G] Fle Edit View Schedue Tools

w (Document1*)]

Window  Help

DedaR[r=eeetSndEerclehaals

P EEE =0 ~[onens B

Views 42001 12/8/2001 121162001 12/23/2001 12/30/2001 1462002
w 7 W[t [ 5 I5 [ [T Tw 7 [¢ [ [5 [w [T [w 7 T¢ [s [s [w[x [wl7 T¢ Ts [s [w[x [wlt [F I5]s [w T

PESTIEPTOCr = 12/1972001

6 |33 E =0 e (o] m |E el |

[ et

otk

[ Sanpl Proect

Handout_T.doc - Mir... [ S]Gigaproject - [Netw... B)Documentz - Miroso...|

[ w1

| sosoens

POLBD sazrm




Figure T.T.4

Many experienced users will indicate that they like to start by blocking the plan out on a white board and then enter the information into the Gantt Chart. The Network Diagram is essentially a Computerized White Board with an infinite width and height. Once activities have been placed on the board they can be moved as many times as needed until you are ready to lock them into the network structure. The primary reason for using the Network view to input information is to allow you to add something called dependencies. While dependencies can be shown in the Gantt view, they are not easy to read once you get more than about 10 of them on the screen.


Our next step is to add an activity. There are several ways to do this, however the easiest way is to Right Click the mouse where you would like to place the activity. The local menu will appear (as shown in Figure T.T.5). Select the “Add Planning Object” option and select the “Activity” sub option. 
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Figure T.T.5

This will result in the ‘Activity Information” dialog box being displayed as shown in figure T.T.6. Notice the red “X” in figure T.T.6, this is a mistake in Turbo/Giga Project, this should not be a writeable field. Do not enter a date into these boxes from this tab. (The Early Start and Early Finish dates are calculated fields, not user defined fields).
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Figure T.T.6

Give the Activity a name and a original duration, then click the “OK” button. This will result in an activity being placed in the Network Diagram as shown in figure T.T.7.

We will now jump ahead for a moment where we have placed 5 activities on the network diagram. We would now like to add a dependency to the project plan. If we look at figure T.T.8 I have entered two activities. The first is names “Go Shopping” and the second is named “Cook”. Since we know that we must complete our shopping effort before we can begin to cook the meal we have planned, we want to represent that “dependency” with a “Finish to Start” dependency from the “Go Shopping” activity to the “Cook” activity.
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Figure T.T.7

In order to make this happen we will use the mouse to click on the back (right end) of the “Go Shopping” activity. The dependency status box will pop up and the mouse will have a chain attached to it. Now click on the front (left end) of the “Cook” activity.
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Figure T.T.8

The Connection dialog box allows you to change the type of dependency/link, we can accept the Finish to Start link by clicking the “OK” button. That’s it you have added activities and dependencies.

Starting and Setting the Defaults on Microsoft Project (MSP)

Depending on where you have installed Microsoft Project you should be able to find it using the “Start” menu and then select “Programs”.  If you leave the installation defaults in place, MSP should be located in the position shown in figure T.1. Click on Microsoft Project to start the Application. 

When the application starts you may or may not get the “Welcome to Microsoft Project” window. This window offers some quasi-useful training tools, which you can go through on your own. If you do use these tools, remember that they are designed for people with no Project Management experience. It is sort of like training someone who has never been in a car how to drive a car. You might not tell them the right way to do something the first time around, you may concentrate on things they can understand first. Hence, if you use theses tools, concentrate on learning where things are. To continue with this discussion, close the “Welcome to Microsoft Project” window by clicking on the “X” in the upper right hand corner of the window.
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Figure T.1

Changing Default View

When you first open Microsoft Project (MSP) the view is set to the Gantt chart. So right off the bat we want to change the default view to the Network or PERT Chart view (prior to Project 2000 the view is called the PERT Chart view, which is actually misleading, in Project 2000 the view is called the network view). To make this change select the “Tools” option from the menu bar and select “Options” from the tools menu as shown in figure T.2.  This will bring up the Options window shown in Figure T.3. If the “View” tab is not selected, select it now.
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Figure T.2





Figure T.3

The first item on the View tab of the Options window is “Default View”. Use the drop down menu to the right of this option and select either  “Pert Chart” or “Network” as your default View. Select “OK” to close this window. Once you have closed the window you may have to manually change the view the first time, after that you should automatically open to the appropriate view for entering information. If you need to change the view manually select the “View” option on the menu bar and then select the  “Pert Chart” or “Network” option from the View menu (as shown in Figure T.4). You should end up with a screen that looks like Figure T.5. 

If you have a gray bar running down the left of your screen which shows the different views, we want to turn this off. To do this select the “View” menu and remove the check from the “View Bar” option in the View menu. You can see this option in Figure T.4.
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Figure T.4
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Figure T.5

Once you have your screen set up to look like Figure T.5 you are ready to start entering Time Based activities or Tasks on your project.

Entering A Task into Your Model

To enter a task into your model just click anywhere in the open area and drag the mouse down to the right. When you release the mouse button a box will appear. You can use these boxes to enter key information and create a framework quickly. You can also “Right Click” on the box and select “Task Information” from the local menu to get a detailed entry form for the selected task. Figure T.6 shows a task which has just been entered with the local menu activated.
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Figure T.6

Figure T.7 shows the Detailed entry form for the task in question. Notice that I have added a big red “X” over the areas that we will never use during the information input process. These options should not be on this tab. These options are responsible for fooling beginning Project Managers, and their resulting crash and burn projects.
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Figure T.7

There are faster ways to load a project and we will discuss these at a later date. Using the Network view to enter project information is the best way to insure that no key elements are omitted. The 3 elements of information that we will always want to enter during the development of a new project are 1) The name of the task, 2) The duration of the task and 3) the WBS of the task. Since the default settings of MSP do not facilitate this information subset, we need to modify the layout of the network view. In order to modify the 

layout of the boxes in the Network view select  “Format” from the menu bar and choose “Box Styles” from the Format menu. (see Figure T.8) Once you have the Box Styles window open, you want to select the “Boxes” tab. When the Boxes tab is open you should be able to see five areas that allow you to specify what information from the Project Model is displayed in each box. Box number 1 should already be set to “Name”, this is the default setting. Set Box 2 to “WBS”. Use the pull down menu to the right of each box to change the setting. Box 3 should be set to “Duration”, this is the default setting. Change the remaining two boxes to anything that is not a date. For example, set Box 4 to “Project” and Box 5 to “Resource Initials”. We do not want any time information showing while we are entering the project information. Figure T.9 shows a view of the Box Tab.
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Figure T.8
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Figure T.9

Figure T.9 also shows the minimum setup for any project or sub project done in this class. To be specific, a Starting Milestone, a Finishing Milestone and atleast one activity where work is performed. 

Lets look at these minimum elements in more detail. In figure T.10 I have revised the elements shown in the Network View to be more real and I have annotated the screen shot so you can see the names of the elements shown. As you can see there are two types of boxes shown the box in the middle is called a 
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Figure T.10

“Task” or “Activity”. Your Project Plan should have one of these boxes for each element of work in your project which you intend to track. On either side there are Tasks with a Duration of 0. This by definition is called a “Milestone”. A milestone is a point in time that recognizes some accomplishment in your project. They are frequently major events and are used to report status to management. Each of these boxes are connected by a line which represents a relationship or dependency between the two boxes. In this case the dependencies indicate that: I must start the Project before I can Perform the Project and I must Perform the Project before I can Finish the Project. I can also say that “Start Project” is a Predecessor of “Perform Project” and that “Finish Project” is a Successor of “Perform Project”.

On all the projects you develop in this class you will always have 1 and only 1 Milestone which has no (Internal) Predecessor and 1 and only 1 Milestone which has no (Internal) Successor. The first Milestone will always be “Start something” where “something” is the name of the Project or Sub-Project” and the last Milestone will always be “Finish something” where “something” is the name of the Project or Sub-Project”. The primary reason for this is to allow you to use the computers forward and backward pass to determine if you have missed anything. When I have talked about these milestones above, I used the phrase “internal milestones”. You will have external milestones which will be connections between two or more projects. These external milestones (also called “Interface Milestones” or “Interim Milestones”) will be used to connect your project to other efforts on which your project depends or on other projects that depend on your project. 

Now that we have seen both tools let’s make some comparisons. In Figure T.11 we can see the same 3 elements we just talked about for MSP in the Turboproject Network View.
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Figure T.11

Let’s compare some of the features. First of all the TurboProject is a timescaled network diagram. This view is not available in Microsoft Project. Also notice that the Milestones are more representative of what they are. Also notice how much more I can get on the screen and still be able to read it. In this version the timescale could not be set to “project days” this is a problem when we start out but once the project is going it is not a problem. I have also left the Project Tree view open. This is the window on the left side of the screen which contains both the WBS structure information and the Sub-Project information. This view is not available in MS Project, and we will see how powerful it is later in the class.

I have moved ahead and entered several tasks so you can see what they look like. Figure 2.12 shows a portion of plan for this class in Microsoft Project. In order to fit it all on one screen in a readable format would take a considerable amount of manual repositioning. In Figure T.13 I show the same project in TurboProject. While it is still difficult to see what each tack is without clicking on it to get more detail, the TurboProject version gives a much better feel for what the project is all about.

Notice that the Microsoft Project version of the Network diagram does not show the relative time differences between the activities. In other words an activity that is one day long looks the same as an activity that is 20 days long. However, in the TurboProject view each activity is sized based on it’s duration so you can tell the difference between long activities and short activities. In addition notice in both versions how we can maintain “Flows” of like activities on the same line, allowing us to make efficient use of the available space on the chart. This is something we cannot do in the Gantt chart.
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Figure T.12
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Figure T.13
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